summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-27 01:26:09 -0400
committerMark H Weaver <mhw@netris.org>2018-05-27 01:26:09 -0400
commit1640f16e7888291227d11647dbb5f83ad5d138a1 (patch)
treebf979aa4e6538b8261762cfbb80512ebb023b016 /gnu/packages/image.scm
parent0ff4e49a95d8a54cd5508f441b927a670d348519 (diff)
parenta4e45acdc07fc3faf2844b3658ee31ebc538bd1c (diff)
downloadgnu-guix-1640f16e7888291227d11647dbb5f83ad5d138a1.tar
gnu-guix-1640f16e7888291227d11647dbb5f83ad5d138a1.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 7291ecd620..37d51f1e51 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1392,3 +1393,50 @@ Features:
images stored in the JPEG format with R. It can read and write both files and
in-memory raw vectors.")
(license license:gpl2+)))
+
+(define-public gifsicle
+ (package
+ (name "gifsicle")
+ (version "1.91")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.lcdf.org/gifsicle/gifsicle-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00586z1yz86qcblgmf16yly39n4lkjrscl52hvfxqk14m81fckha"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'patch-tests
+ (lambda _
+ (substitute* "test/testie"
+ (("/usr/bin/perl")
+ (which "perl"))
+ (("/bin/sh")
+ (which "sh"))
+ (("/bin/rm")
+ (which "rm")))
+ #t)))))
+ (native-inputs `(("perl" ,perl))) ; Only for tests.
+ (inputs `(("libx11" ,libx11)))
+ (home-page "http://www.lcdf.org/gifsicle/")
+ (synopsis "Edit GIF images and animations")
+ (description "Gifsicle is a command-line GIF image manipulation tool that:
+
+@itemize
+@item Provides a batch mode for changing GIFs in place.
+@item Prints detailed information about GIFs, including comments.
+@item Control over interlacing, comments, looping, transparency, etc.
+@item Creates well-behaved GIFs: removes redundant colors, only uses local color
+tables, etc.
+@item Shrinks colormaps and change images to use the Web-safe palette.
+@item Optimizes GIF animations, or unoptimizes them for easier editing.
+@end itemize
+
+Two other programs are included with Gifsicle: @command{gifview} is a
+lightweight animated-GIF viewer, and @command{gifdiff} compares two GIFs for
+identical visual appearance.")
+ (license license:gpl2+)))