summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 01:24:07 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:21 +0200
commitdc676afb8cf4b0a9b44d630c917dfdb996e597ee (patch)
treef7471ba989a8eac9d434ea2af45cf90d0936a1da /gnu/packages/haskell.scm
parente4bc57c85bb3ec8bc8eef35f3ff0fd3d1cb4b267 (diff)
downloadgnu-guix-dc676afb8cf4b0a9b44d630c917dfdb996e597ee.tar
gnu-guix-dc676afb8cf4b0a9b44d630c917dfdb996e597ee.tar.gz
gnu: ghc-trifecta: Update to 2.
* gnu/packages/haskell.scm (ghc-trifecta): Update to 2. [inputs]: Remove ghc-doctest-0.13, ghc-doctest, and ghc-quickcheck. [native-inputs]: Add ghc-doctest and ghc-quickcheck.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7c1c4af8f2..aebe223193 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2944,7 +2944,7 @@ the parsers provided by @code{parsec}, @code{attoparsec} and @code{base}'s
(define-public ghc-trifecta
(package
(name "ghc-trifecta")
- (version "1.7.1.1")
+ (version "2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2952,11 +2952,10 @@ the parsers provided by @code{parsec}, @code{attoparsec} and @code{base}'s
"trifecta-" version ".tar.gz"))
(sha256
(base32
- "13n6a3fdxngnzsjnhfrzigv1c2g0xm6lqkjcnirpc37sd0rpby31"))))
+ "0hznd8i65s81xy13i2qc7cvipw3lfb2yhkv53apbdsh6sbljz5sk"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-doctest" ,ghc-doctest-0.13)
- ("ghc-reducers" ,ghc-reducers)
+ `(("ghc-reducers" ,ghc-reducers)
("ghc-semigroups" ,ghc-semigroups)
("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
("ghc-ansi-terminal" ,ghc-ansi-terminal)
@@ -2965,17 +2964,17 @@ the parsers provided by @code{parsec}, @code{attoparsec} and @code{base}'s
("ghc-blaze-markup" ,ghc-blaze-markup)
("ghc-charset" ,ghc-charset)
("ghc-comonad" ,ghc-comonad)
- ("ghc-doctest" ,ghc-doctest)
("ghc-fingertree" ,ghc-fingertree)
("ghc-hashable" ,ghc-hashable)
("ghc-lens" ,ghc-lens)
("ghc-parsers" ,ghc-parsers)
("ghc-profunctors" ,ghc-profunctors)
- ("ghc-quickcheck" ,ghc-quickcheck)
("ghc-unordered-containers" ,ghc-unordered-containers)
("ghc-utf8-string" ,ghc-utf8-string)))
(native-inputs
- `(("cabal-doctest" ,cabal-doctest)))
+ `(("cabal-doctest" ,cabal-doctest)
+ ("ghc-doctest" ,ghc-doctest)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
(home-page "https://github.com/ekmett/trifecta/")
(synopsis "Parser combinator library with convenient diagnostics")
(description "Trifecta is a modern parser combinator library for Haskell,