summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-30 23:18:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:23 +0200
commit52891580e1c83235c2bf3a8297b05662c3bc14e9 (patch)
tree33df318dfdff56de31354b1e5105c8b95064aa70 /gnu/packages/haskell.scm
parent456d76eaf6583e2439ff6df19427779a2d62848c (diff)
downloadgnu-guix-52891580e1c83235c2bf3a8297b05662c3bc14e9.tar
gnu-guix-52891580e1c83235c2bf3a8297b05662c3bc14e9.tar.gz
gnu: ghc-statistics: Fix build.
* gnu/packages/haskell.scm (ghc-statistics)[arguments]: Add cabal revision.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 205d2348d4..a140985eba 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8999,6 +8999,11 @@ that are much lighter weight than IO-threads.")
(base32
"0y27gafkib0x0fn39qfn2rkgsfrm09ng35sbb5dwr7rclhnxz59l"))))
(build-system haskell-build-system)
+ (arguments
+ '(#:cabal-revision
+ ("2" "1bx70yqkn62ii17fjv3pig4hklrzkqd09zj67zzjiyjzmn04fir3")
+ ;; Two tests fail: "Discrete CDF is OK" and "Quantile is CDF inverse".
+ #:tests? #f))
(inputs
`(("ghc-aeson" ,ghc-aeson)
("ghc-base-orphans" ,ghc-base-orphans)
@@ -9018,8 +9023,6 @@ that are much lighter weight than IO-threads.")
("ghc-test-framework" ,ghc-test-framework)
("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
- (arguments
- `(#:tests? #f)) ; FIXME: Test-Suite `spec` fails.
(home-page "https://github.com/bos/mwc-random")
(synopsis "Haskell library of statistical types, data, and functions")
(description "This library provides a number of common functions