summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:24:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:11 +0200
commit828c9ff83180efe4a8d894738c38360f45552e81 (patch)
treeeece3d188796e99b915c42d175f078bf617d6e37 /gnu/packages/haskell-web.scm
parent6c7a3279adcac004080dc0771e8bf6822d3a28a2 (diff)
downloadgnu-guix-828c9ff83180efe4a8d894738c38360f45552e81.tar
gnu-guix-828c9ff83180efe4a8d894738c38360f45552e81.tar.gz
gnu: ghc-http-conduit: Update to 2.3.2.
* gnu/packages/haskell-web.scm (ghc-http-conduit): Update to 2.3.2. [inputs]: Add ghc-unliftio.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index e5ac001fad..a853eb3cdc 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -318,15 +318,16 @@ and HPACK. Currently HTTP/2 16 framing and HPACK 10 is supported.")
(define-public ghc-http-conduit
(package
(name "ghc-http-conduit")
- (version "2.2.4")
+ (version "2.3.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"http-conduit-" version "/" "http-conduit-"
version ".tar.gz"))
- (sha256 (base32
- "1wcl3lpg4v1ylq9j77j9fmf6l9qbmp8dmj3a9829q19q6bbgza7l"))))
+ (sha256
+ (base32
+ "1iay4hr0mj8brkxvgkv1liqa8irl9axfc3qhn8qsvcyq4n1l95km"))))
(build-system haskell-build-system)
;; FIXME: `httpLbs TLS` in test-suite `test` fails with
;; ConnectionFailure getProtocolByName: does not exist (no such protocol
@@ -343,7 +344,8 @@ and HPACK. Currently HTTP/2 16 framing and HPACK 10 is supported.")
("ghc-http-client-tls" ,ghc-http-client-tls)
("ghc-monad-control" ,ghc-monad-control)
("ghc-mtl" ,ghc-mtl)
- ("ghc-exceptions" ,ghc-exceptions)))
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-unliftio" ,ghc-unliftio)))
(native-inputs
`(("ghc-hunit" ,ghc-hunit)
("ghc-hspec" ,ghc-hspec)