summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:44:45 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:25:44 +0200
commit122260b390c13e21128ef7312f9c64357f947da7 (patch)
treea6d763dd585e9108a727af3c2c5fe08dfd7c514f /gnu/packages/haskell-web.scm
parent448d6226e35dbeaed58a4a0145cc7b539ed6e0b4 (diff)
downloadgnu-guix-122260b390c13e21128ef7312f9c64357f947da7.tar
gnu-guix-122260b390c13e21128ef7312f9c64357f947da7.tar.gz
gnu: Add ghc-skein.
* gnu/packages/haskell-web.scm (ghc-skein): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index edfb43c085..04d4bd24cd 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -925,3 +925,31 @@ of a JSON value into a @code{Data.Aeson.Value}.")
(description "This Haskell package provides two typeclasses for converting
Haskell data types to and from route pieces.")
(license license:bsd-3)))
+
+(define-public ghc-skein
+ (package
+ (name "ghc-skein")
+ (version "1.0.9.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "skein-" version "/"
+ "skein-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jdqdk0rz2wnvw735clnj8jh0a9rkrbqjg7vk3w6wczdql6cm0pq"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-cereal" ,ghc-cereal)
+ ("ghc-tagged" ,ghc-tagged)
+ ("ghc-crpto-api" ,ghc-crypto-api)))
+ (native-inputs `(("ghc-hspec" ,ghc-hspec)))
+ (home-page "https://github.com/yesodweb/path-pieces")
+ (synopsis "Skein family of cryptographic hash functions for Haskell")
+ (description "@uref{(http://www.skein-hash.info, Skein} is a family of
+fast secure cryptographic hash functions designed by Niels Ferguson, Stefan
+Lucks, Bruce Schneier, Doug Whiting, Mihir Bellare, Tadayoshi Kohno, Jon
+Callas and Jesse Walker.
+
+This Haskell package uses bindings to the optimized C implementation of Skein.")
+ (license license:bsd-3)))