summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 19:25:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:32 +0100
commit7fa02bc7aba851357151e00f8982a6a3524c08c7 (patch)
treed9350f7f1f9d4a9c0399303e454fde3332b6eb34 /gnu/packages/haskell-check.scm
parent4c8a1f4030998dc9020d062352c9fd1f9fb798bd (diff)
downloadgnu-guix-7fa02bc7aba851357151e00f8982a6a3524c08c7.tar
gnu-guix-7fa02bc7aba851357151e00f8982a6a3524c08c7.tar.gz
gnu: ghc-test-framework: Fix build with GHC 8.
* gnu/packages/haskell-check.scm (ghc-test-framework)[arguments]: Permit building with newer version of "time".
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index ddd2742a78..a48a4d5c64 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -446,6 +446,8 @@ expressed in Haskell, using combinators defined in the QuickCheck library.")
(base32
"0wxjgdvb1c4ykazw774zlx86550848wbsvgjgcrdzcgbb9m650vq"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:configure-flags (list "--allow-newer=time")))
(native-inputs
`(("ghc-hunit" ,ghc-hunit)
("ghc-quickcheck" ,ghc-quickcheck)))