summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-14 11:04:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-14 11:04:40 +0300
commitc2397a869549b6786b801ab816acdba68555494a (patch)
treeb8aa0cc0aa281069cb33f46a03620416a7599b02 /gnu/packages/gtk.scm
parent0ea6af996b06ba453b803f2d4b014ffa709db4b7 (diff)
downloadgnu-guix-c2397a869549b6786b801ab816acdba68555494a.tar
gnu-guix-c2397a869549b6786b801ab816acdba68555494a.tar.gz
gnu: gdk-pixbuf: Increase test timeout.
* gnu/packages/gtk.scm (gdk-pixbuf)[arguments]: Increase test timeout.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index ccedec6398..cec10504c5 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -469,7 +469,11 @@ highlighting and other features typical of a source code editor.")
;; ERROR:pixbuf-jpeg.c:74:test_type9_rotation_exif_tag:
;; assertion failed (error == NULL): Data differ
;; (gdk-pixbuf-error-quark, 0)
- ((".*'pixbuf-jpeg'.*") ""))
+ ((".*'pixbuf-jpeg'.*") "")
+ ;; Extend the timeout of the test suite.
+ ;; TODO: Check upstreaming effort:
+ ;; https://gitlab.gnome.org/GNOME/gdk-pixbuf/merge_requests/21
+ (("300") "1800"))
#t))
(add-before 'configure 'aid-install-script
(lambda* (#:key outputs #:allow-other-keys)