summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-11-09 19:17:05 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-11-11 16:41:45 +0100
commit50ee7e93fcd881d3bf996954bcd5176aa7c54d21 (patch)
tree7947931ca6abd3f77c8e4f8cd33df376eb21f5ee /gnu/packages/gtk.scm
parent89c7894805329023754512c9b30e67ceb1753cb0 (diff)
downloadgnu-guix-50ee7e93fcd881d3bf996954bcd5176aa7c54d21.tar
gnu-guix-50ee7e93fcd881d3bf996954bcd5176aa7c54d21.tar.gz
gnu: gtk-doc: Use local docbook-xsl.
* gnu/packages/gtk.scm (gtk-doc): Use local docbook-xsl.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 640bd75da4..0d62b80833 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1411,7 +1412,12 @@ information.")
(string-append (assoc-ref inputs "docbook-xsl")
"/xml/xsl/docbook-xsl-"
,(package-version docbook-xsl)
- "/html/chunk.xsl")))
+ "/html/chunk.xsl"))
+ (("http://docbook.sourceforge.net/release/xsl/current/common/en.xml")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/common/en.xml")))
#t))
(add-after 'patch-gtk-doc-scan 'patch-test-out
(lambda _