summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRouby Pierre-Antoine <pierre-antoine.rouby@inria.fr>2018-07-10 18:06:08 +0200
committerLudovic Courtès <ludo@gnu.org>2018-07-13 00:08:55 +0200
commitabd47216b70d6590322a75e6d6f7e85639c82077 (patch)
tree71d038969a5db746c4df2ea8cdea52ba4c34d3a1 /gnu/packages/golang.scm
parentd850e7a0b7c0f35dc3ef39187e9f15c51723bd31 (diff)
downloadgnu-guix-abd47216b70d6590322a75e6d6f7e85639c82077.tar
gnu-guix-abd47216b70d6590322a75e6d6f7e85639c82077.tar.gz
gnu: Add go-gopkg-in-check-v1.
* gnu/packages/golang.scm (go-gopkg-in-check-v1): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bcd524dd2a..9393d39d51 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1922,3 +1922,28 @@ Given a cron expression and a time stamp, you can get the next time stamp
which satisfies the cron expression.")
(license (list license:gpl3+
license:asl2.0)))))
+
+(define-public go-gopkg-in-check-v1
+ (let ((commit "20d25e2804050c1cd24a7eea1e7a6447dd0e74ec")
+ (revision "0"))
+ (package
+ (name "go-gopkg-in-check-v1")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-check/check")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0k1m83ji9l1a7ng8a7v40psbymxasmssbrrhpdv2wl4rhs0nc3np"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gopkg.in/check.v1"))
+ (home-page "https://gopkg.in/check.v1")
+ (synopsis "Test framework for the Go language")
+ (description
+ "This package provides a test library for the Go language.")
+ (license license:asl2.0))))