summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 14:39:35 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 14:41:44 +0200
commit5b6c3ad0cda0f50843cbaaafc27c0482109b1e23 (patch)
tree87e485272eb453d3b97001a8cc0e93ce95256b0e /gnu/packages/golang.scm
parent96bdf904ac625e3ded6be745ed821339ca467ce5 (diff)
downloadgnu-guix-5b6c3ad0cda0f50843cbaaafc27c0482109b1e23.tar
gnu-guix-5b6c3ad0cda0f50843cbaaafc27c0482109b1e23.tar.gz
gnu: Add go-github-com-kr-fs.
* gnu/packages/golang.scm (go-github-com-kr-fs): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9b469072c4..60d3ee7ad9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3310,3 +3310,27 @@ fast and distributable command line applications in an expressive way.")
(description "A simple log library, for when you don't really care to
have super fancy logs.")
(license license:expat))))
+
+(define-public go-github-com-kr-fs
+ (let ((commit "1455def202f6e05b95cc7bfc7e8ae67ae5141eba")
+ (revision "0"))
+ (package
+ (name "go-github-com-kr-fs")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kr/fs.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11zg176x9hr9q7fsk95r6q0wf214gg4czy02slax4x56n79g6a7q"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/kr/fs"))
+ (home-page "https://github.com/kr/fs")
+ (synopsis "Filesystem-related functions for Go")
+ (description "Package fs provides filesystem-related functions.")
+ (license license:bsd-3))))