summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-29 15:37:05 -0500
committerLeo Famulari <leo@famulari.name>2017-12-31 12:36:07 -0500
commit11b12655f0541c23f4073f7476b9de0c595f6587 (patch)
tree9488bb401197e60457e9dfafb7af4be38199b365 /gnu/packages/golang.scm
parentd3878e88f3b5a3b94b7cdb46b508ec726d399572 (diff)
downloadgnu-guix-11b12655f0541c23f4073f7476b9de0c595f6587.tar
gnu-guix-11b12655f0541c23f4073f7476b9de0c595f6587.tar.gz
gnu: Add go-github-com-aki237-nscjar.
* gnu/packages/golang.scm (go-github-com-aki237-nscjar): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0a4709d684..e22a099b9b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -404,3 +404,27 @@ case for these are for command-line applications but alternate progress bar
writers can be supplied for alternate environments.")
(home-page "https://github.com/alsm/ioprogress")
(license license:expat))))
+
+(define-public go-github-com-aki237-nscjar
+ (let ((commit "e2df936ddd6050d30dd90c7214c02b5019c42f06")
+ (revision "0"))
+ (package
+ (name "go-github-com-aki237-nscjar")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aki237/nscjar.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "03y7zzq12qvhsq86lb06sgns8xrkblbn7i7wd886wk3zr5574b96"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/aki237/nscjar"))
+ (synopsis "Handle Netscape / Mozilla cookies")
+ (description "@code{nscjar} is a Go library used to parse and output
+Netscape/Mozilla's old-style cookie files. It also implements a simple cookie
+jar struct to manage the cookies added to the cookie jar.")
+ (home-page "https://github.com/aki237/nscjar")
+ (license license:expat))))