summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-18 14:52:04 -0400
committerLeo Famulari <leo@famulari.name>2016-08-18 14:53:52 -0400
commit7deb5ee89917680a1326ec8036861dbc37a0578e (patch)
tree2867a6848674b199298d89f0952fef0fad02fe6e /gnu/packages/gnupg.scm
parent995e8baf97d07ee37aac49995838560800ee5d92 (diff)
downloadgnu-guix-7deb5ee89917680a1326ec8036861dbc37a0578e.tar
gnu-guix-7deb5ee89917680a1326ec8036861dbc37a0578e.tar.gz
gnu: gnupg: Update to 2.1.15.
* gnu/packages/gnupg.scm (gnupg): Update to 2.1.15. [arguments]: Add 'patch-scheme-tests' phase.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 989496f4ac..27db5c3d76 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -209,14 +209,14 @@ compatible to GNU Pth.")
(define-public gnupg
(package
(name "gnupg")
- (version "2.1.13")
+ (version "2.1.15")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/gnupg/gnupg-" version
".tar.bz2"))
(sha256
(base32
- "0xcn46vcb5x5qx0bc803vpzhzhnn6wfhp7x71w9n1ahx4ak877ag"))))
+ "1pgz02gd84ab94w4xdg67p9z8kvkyr9d523bvcxxd2hviwh1m362"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -242,7 +242,12 @@ compatible to GNU Pth.")
(lambda _
(substitute* "tests/openpgp/defs.inc"
(("/bin/pwd") (which "pwd")))
- #t)))))
+ #t))
+ (add-after 'build 'patch-scheme-tests
+ (lambda _
+ (substitute* (find-files "tests" ".\\.scm$")
+ (("/usr/bin/env gpgscm")
+ (string-append (getcwd) "/tests/gpgscm/gpgscm"))))))))
(home-page "https://gnupg.org/")
(synopsis "GNU Privacy Guard")
(description