summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2018-02-25 06:49:54 +0800
committerMarius Bakke <mbakke@fastmail.com>2018-02-28 16:57:33 +0100
commit451f6e30ebfc32a8679daa71f8ff438ca03c73d1 (patch)
treef7b985f5cb97f74e27b54bb70c27fa26a4943d60 /gnu/packages/glib.scm
parent4e028d7ad2f5119663bba80e7c258e6141f4cf27 (diff)
downloadgnu-guix-451f6e30ebfc32a8679daa71f8ff438ca03c73d1.tar
gnu-guix-451f6e30ebfc32a8679daa71f8ff438ca03c73d1.tar.gz
gnu: Add perl-glib.
* gnu/packages/glib.scm (perl-glib): New public variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 45d0d891c4..a64407a36f 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -622,6 +623,33 @@ useful for C++.")
("python-pycairo" ,python2-pycairo)
("gobject-introspection" ,gobject-introspection)))))
+(define-public perl-glib
+ (package
+ (name "perl-glib")
+ (version "1.326")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/X/XA/XAOC/Glib-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0prn9kkdpwjq9qmzqashbhk3pq4gvlrmvm3b10xf1dhc48406382"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-extutils-depends" ,perl-extutils-depends)
+ ("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)))
+ (inputs
+ `(("glib" ,glib)))
+ (home-page "http://search.cpan.org/dist/Glib/")
+ (synopsis "Perl wrappers for the GLib utility and Object libraries")
+ (description "This module provides perl access to GLib and GLib's GObject
+libraries. GLib is a portability and utility library; GObject provides a
+generic type system with inheritance and a powerful signal system. Together
+these libraries are used as the foundation for many of the libraries that make
+up the Gnome environment, and are used in many unrelated projects.")
+ (license license:lgpl2.1+)))
+
(define telepathy-glib
(package
(name "telepathy-glib")