summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-02-17 16:42:13 -0500
committerLeo Famulari <leo@famulari.name>2018-03-15 10:57:51 -0400
commit24fb9a55918655cada3bd3cb070aaf02f382e109 (patch)
tree91b61d99bad3a1f2130640ceb0cb13779f4c4fba /gnu/packages/geo.scm
parent9ddf42099b398d107467bc42bb495a20f502925f (diff)
downloadgnu-guix-24fb9a55918655cada3bd3cb070aaf02f382e109.tar
gnu-guix-24fb9a55918655cada3bd3cb070aaf02f382e109.tar.gz
gnu: Add r-geosphere.
* gnu/packages/geo.scm (r-geosphere): New variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b6b185e5cb..29d8265eb8 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages cran)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
@@ -555,3 +556,23 @@ interface to query the Google server for static maps, and (ii) Use the map as a
background image to overlay plots within R. This requires proper coordinate
scaling.")
(license license:gpl2+)))
+
+(define-public r-geosphere
+ (package
+ (name "r-geosphere")
+ (version "1.5-7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "geosphere" version))
+ (sha256
+ (base32
+ "186qdm5niq7v3d4w4rngx71znsgi44hnam7698bsx9ar5mg5b6wx"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-sp" ,r-sp)))
+ (home-page "https://cran.r-project.org/web/packages/geosphere")
+ (synopsis "Spherical trigonometry")
+ (description "This package computes spherical trigonometry for geographic
+applications. That is, compute distances and related measures for angular
+(longitude/latitude) locations.")
+ (license license:gpl3+)))