summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-08-30 14:38:10 +0200
committerLudovic Courtès <ludo@gnu.org>2015-08-30 18:38:08 +0200
commitb7c7c03eb5e37fc3455e4e17b0898ffc4bca29c3 (patch)
treea9c2d06e8cb6a9049f13246b6665c960f48bb13b /gnu/packages/gcc.scm
parentd56f8d5e749496362d76bbbf364c8eba2260c6e5 (diff)
downloadgnu-guix-b7c7c03eb5e37fc3455e4e17b0898ffc4bca29c3.tar
gnu-guix-b7c7c03eb5e37fc3455e4e17b0898ffc4bca29c3.tar.gz
utils: Add 'strip-store-file-name'.
* guix/build/utils.scm (strip-store-file-name): New procedure. * guix/build/emacs-build-system.scm (store-directory->name-version): Remove. Update callers to use 'strip-store-file-name'. * gnu/packages/gcc.scm (make-libstdc++-doc)[arguments]: Use 'strip-store-file-name' instead of 'string-drop'.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 761d3a6998..dcac16d752 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -578,11 +578,7 @@ using compilers other than GCC."
(("@XSL_STYLE_DIR@")
(string-append
docbook "/xml/xsl/"
- (string-drop
- docbook
- (+ 34
- (string-length
- (%store-directory))))))))))
+ (strip-store-file-name docbook)))))))
(replace 'build
(lambda _
;; XXX: There's also a 'doc-info' target, but it