summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 17:58:32 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-13 01:51:48 +0200
commite08474d650f144ecc73614b9655684b92000293d (patch)
tree2679416812821f017cf632a418fc7edf5c81f366 /gnu/packages/games.scm
parentb3ce80d20f7533383cd87e5c7b9596dd701052e9 (diff)
downloadgnu-guix-e08474d650f144ecc73614b9655684b92000293d.tar
gnu-guix-e08474d650f144ecc73614b9655684b92000293d.tar.gz
gnu: fortune-mod: Clean up empty directory.
* gnu/packages/games.scm (fortune-mod)[arguments]: RMDIR ‘games/’ after emptying it.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9b726cf129..a16ecb81a8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5218,11 +5218,16 @@ Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
(chdir "fortune-mod")
#t)))
(add-after 'install 'fix-install-directory
- ;; Move binary from "games/" to "bin/".
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (rename-file (string-append out "/games/fortune")
- (string-append out "/bin/fortune"))
+ ;; Move binary from "games/" to "bin/" and remove the latter. This
+ ;; is easier than patching CMakeLists.txt since the tests hard-code
+ ;; the location as well.
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (games (string-append out "/games")))
+ (rename-file (string-append games "/fortune")
+ (string-append bin "/fortune"))
+ (rmdir games)
#t))))))
(inputs `(("recode" ,recode)))
(native-inputs