summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-21 00:26:15 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-30 19:28:11 +0200
commit8294362688096145547464ceaa25edd5cc65d024 (patch)
treef3e42bdc2d1041cf94ad99b4804fa3d53974aadd /gnu/packages/games.scm
parent6e8c75b88435550906e251dd4a9c2eb732f803d4 (diff)
downloadgnu-guix-8294362688096145547464ceaa25edd5cc65d024.tar
gnu-guix-8294362688096145547464ceaa25edd5cc65d024.tar.gz
gnu: Add pipewalker.
* gnu/packages/games.scm (pipewalker): New public variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0142fc8ed2..3c5063f69b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -793,6 +793,46 @@ role, and your gender.")
(license:fsdg-compatible
"https://nethack.org/common/license.html"))))
+(define-public pipewalker
+ (package
+ (name "pipewalker")
+ (version "0.9.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://downloads.sourceforge.net/pipewalker/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1x46wgk0s55562pd96cxagxkn6wpgglq779f9b64ff1k3xzp3myn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--docdir=" (assoc-ref %outputs "out")
+ "/share/doc/" ,name "-" ,version))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'patch-docdir
+ ;; Makefile.in ignores configure's ‘--docdir=...’ option. Fix that.
+ (lambda _
+ (substitute* "Makefile"
+ (("(pkgdocdatadir = ).*" _ assignment)
+ (string-append assignment "$(docdir)\n")))
+ #t)))))
+ (inputs
+ `(("libpng" ,libpng)
+ ("mesa" ,mesa)
+ ("sdl" ,sdl)))
+ (home-page "http://pipewalker.sourceforge.net/")
+ (synopsis "Logical tile puzzle")
+ (description
+ "PipeWalker is a simple puzzle game with many diffent themes: connect all
+computers to one network server, bring water from a source to the taps, etc.
+The underlying mechanism is always the same: you must turn each tile in the
+grid in the right direction to combine all components into a single circuit.
+Every puzzle has a complete solution, although there may be more than one.")
+ (license license:gpl3+)))
+
(define-public prboom-plus
(package
(name "prboom-plus")