summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-12-20 23:16:56 -0600
committerEric Bavier <bavier@member.fsf.org>2018-12-20 23:20:25 -0600
commit39c676c4a3507863f4edf20b225ace4cbf646ed6 (patch)
tree2cf791ddf1da898c6cbf52afc192b2d6570fdb9a /gnu/packages/games.scm
parent18ebaa9eeb01e3a2f9963281d5dc5e3866d40ea4 (diff)
downloadgnu-guix-39c676c4a3507863f4edf20b225ace4cbf646ed6.tar
gnu-guix-39c676c4a3507863f4edf20b225ace4cbf646ed6.tar.gz
gnu: Add Quadrapassel.
* gnu/packages/games.scm (quadrapassel): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index cff717b233..7b8d2f1bae 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -146,6 +146,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages messaging)
#:use-module (gnu packages networking)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system haskell)
@@ -5904,3 +5905,43 @@ access to game controllers. It supports the de-facto standard gamepads as
defined by the W3C standard Gamepad specification or as implemented by the SDL
GameController.")
(license license:lgpl2.1+)))
+
+(define-public quadrapassel
+ (package
+ (name "quadrapassel")
+ (version "3.31.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "08i01nsgfb502xzzrrcxxbs7awb0j1h4c08vmj0j18ipa1sz8vb8"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ;for desktop-file-validate
+ ("gettext" ,gnu-gettext)
+ ("glib" ,glib "bin") ;for glib-compile-resources
+ ("itstool" ,itstool)
+ ("libxml2" ,libxml2) ;for xmllint
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (inputs
+ `(("clutter" ,clutter)
+ ("clutter-gtk" ,clutter-gtk)
+ ("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
+ ("libmanette" ,libmanette)
+ ("librsvg" ,librsvg)))
+ (home-page "https://wiki.gnome.org/Apps/Quadrapassel")
+ (synopsis "GNOME version of Tetris")
+ (description "Quadrapassel comes from the classic falling-block game,
+Tetris. The goal of the game is to create complete horizontal lines of
+blocks, which will disappear. The blocks come in seven different shapes made
+from four blocks each: one straight, two L-shaped, one square, and two
+S-shaped. The blocks fall from the top center of the screen in a random
+order. You rotate the blocks and move them across the screen to drop them in
+complete lines. You score by dropping blocks fast and completing lines. As
+your score gets higher, you level up and the blocks fall faster.")
+ (license license:gpl2+)))