summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-06 22:43:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-06 22:43:37 +0200
commit116ca65b583ba4e404289f1481dc3a3ffef1c3dd (patch)
tree79796424eb21443c76594304162b6629c3a8a54e /gnu/packages/games.scm
parent477ee222aa796257b5f32966da662e76fe706332 (diff)
parent25133ca172d7dd436c4c08055d18f1a393037dbb (diff)
downloadgnu-guix-116ca65b583ba4e404289f1481dc3a3ffef1c3dd.tar
gnu-guix-116ca65b583ba4e404289f1481dc3a3ffef1c3dd.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 72f284fd15..5568de033b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4484,7 +4484,7 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(arguments
`(#:make-flags
(let ((vulkanlib (string-append (assoc-ref %build-inputs
- "vulkan-icd-loader") "/lib")))
+ "vulkan-loader") "/lib")))
(list "CC=gcc"
"MP3LIB=mpg123"
"USE_CODEC_FLAC=1"
@@ -4497,7 +4497,7 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(add-after 'unpack 'fix-makefile-paths
(lambda* (#:key outputs #:allow-other-keys)
(let ((vulkan (assoc-ref %build-inputs
- "vulkan-icd-loader"))
+ "vulkan-loader"))
(out (assoc-ref outputs "out")))
(mkdir-p (string-append out "/bin"))
(substitute* "Quake/Makefile" ((" /usr")
@@ -4508,7 +4508,7 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
#t))))
,@(strip-keyword-arguments '(#:make-flags #:phases)
(package-arguments quakespasm))))
- (inputs `(("vulkan-icd-loader" ,vulkan-icd-loader)
+ (inputs `(("vulkan-loader" ,vulkan-loader)
,@(package-inputs quakespasm)))
(description "vkquake is a modern engine for id software's Quake 1.
It includes support for 64 bit CPUs, custom music playback, a new sound driver,
@@ -4710,7 +4710,7 @@ Github or Gitlab.")
(define-public colobot
(package
(name "colobot")
- (version "0.1.11-alpha")
+ (version "0.1.11.1-alpha")
(source
(origin
(method url-fetch)
@@ -4718,7 +4718,7 @@ Github or Gitlab.")
"colobot-gold-" version ".tar.gz"))
(sha256
(base32
- "160rq9fp5vd0qaqr3jvzvzrcxk9cac532y8vx4cvq0a8hgylrbad"))))
+ "0h6f4icarramhjkxxbzz6siv3v11z5r8ghqisgr1rscw217vhmwf"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no test
@@ -4756,7 +4756,7 @@ Github or Gitlab.")
"colobot-gold-" version ".tar.gz"))
(sha256
(base32
- "1pdpsyr41g7xmk03k2g76l214f53ahk04qnkzmsv1fdbbaq7p109"))))
+ "0riznycx2jbxmg4m9nn3mcpqws2c0s7cn2m9skz9zj1w39r5qpjy"))))
("colobot-music"
,(origin
(method url-fetch)