summaryrefslogtreecommitdiff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-10-18 22:46:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-10-19 19:34:17 +0200
commit5e270e8e8f5f158dedadb646457a64c7125d54f0 (patch)
tree6ea4c90ef42b626887e8102cb4555304e190b327 /gnu/packages/ftp.scm
parentd5ccf71ec6c0b384fb490e3783772c698866481b (diff)
downloadgnu-guix-5e270e8e8f5f158dedadb646457a64c7125d54f0.tar
gnu-guix-5e270e8e8f5f158dedadb646457a64c7125d54f0.tar.gz
gnu: lftp: Update to 4.7.3.
* gnu/packages/ftp.scm (lftp): Update to 4.7.3. [source]: Use HTTPS. Remove patch. [arguments]: Add ‘disable-impure-tests’ phase. Add #:configure-flags with explicit location of readline headers. [home-page]: Use HTTPS. * gnu/packages/patches/lftp-dont-save-unknown-host-fingerprint.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm25
1 files changed, 18 insertions, 7 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 4c2d893c17..8ef620ce76 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,18 +34,16 @@
(define-public lftp
(package
(name "lftp")
- (version "4.6.1")
+ (version "4.7.3")
(source (origin
(method url-fetch)
- (uri (list (string-append "http://lftp.yar.ru/ftp/lftp-"
+ (uri (list (string-append "https://lftp.yar.ru/ftp/lftp-"
version ".tar.xz")
- (string-append "http://lftp.yar.ru/ftp/old/lftp-"
+ (string-append "https://lftp.yar.ru/ftp/old/lftp-"
version ".tar.xz")))
(sha256
(base32
- "1grmp8zg7cjgjinz66mrh53whigkqzl90nlxj05hapnhk3ns3vni"))
- (patches (search-patches
- "lftp-dont-save-unknown-host-fingerprint.patch"))))
+ "0z4flhqvq9w9md1348jdw0lnk0dlljyicz8597inl6jcvjf2a8iv"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -52,7 +51,19 @@
`(("zlib" ,zlib)
("readline" ,readline)
("gnutls" ,gnutls)))
- (home-page "http://lftp.yar.ru/")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Disable tests that require network access, which is most of them.
+ (add-before 'check 'disable-impure-tests
+ (lambda _
+ (substitute* "tests/Makefile"
+ (("(ftp-cls-l|ftp-list|http-get)\\$\\(EXEEXT\\)") "")
+ (("lftp-https-get ") "")))))
+ #:configure-flags
+ (list (string-append "--with-readline="
+ (assoc-ref %build-inputs "readline")))))
+ (home-page "https://lftp.yar.ru/")
(synopsis "Command-line file transfer program")
(description
"LFTP is a sophisticated FTP/HTTP client, and a file transfer program