summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-08 22:49:54 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-08 23:26:47 +0100
commitdfb01baec4a68833539b3f1ff4f4fb53a367cdcb (patch)
tree0e1351c8a9b91e94a8edc445191d8c5d648d751f /gnu/packages/freedesktop.scm
parentec460a2a376c44e5d27f826873e02586a89a53ca (diff)
downloadgnu-guix-dfb01baec4a68833539b3f1ff4f4fb53a367cdcb.tar
gnu-guix-dfb01baec4a68833539b3f1ff4f4fb53a367cdcb.tar.gz
gnu: Add libfprint.
* gnu/packages/freedesktop.scm (libfprint): New variable.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm36
1 files changed, 35 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 18e609751f..4f00826d77 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Andy Wingo <wingo@pobox.com>
-;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
@@ -42,11 +42,13 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib) ;intltool
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnuzilla)
#:use-module (gnu packages gperf)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libunwind)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages m4)
#:use-module (gnu packages polkit)
@@ -805,3 +807,35 @@ share connections to real-time communication services without conflicting.")
useful for both applications which need colour management and applications that
wish to perform colour calibration.")
(license license:lgpl2.1+)))
+
+(define-public libfprint
+ (package
+ (name "libfprint")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://people.freedesktop.org/~hadess/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1giwh2z63mn45galsjb59rhyrvgwcy01hvvp4g01iaa2snvzr0r5"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags (list (string-append "--with-udev-rules-dir="
+ (assoc-ref %outputs "out")
+ "/lib/udev/rules.d"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libusb" ,libusb)
+ ("nss" ,nss)
+ ("glib" ,glib)
+ ("eudev" ,eudev)
+ ("pixman" ,pixman)))
+ (home-page "https://www.freedesktop.org/wiki/Software/fprint/libfprint/")
+ (synopsis "Library to access fingerprint readers")
+ (description
+ "libfprint is a library designed to make it easy for application
+developers to add support for consumer fingerprint readers to their
+software.")
+ (license license:lgpl2.1+)))