summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 01:57:20 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:41:37 -0400
commit3f54fd1ea58fc8c21393fac466c0b168016b70db (patch)
tree9f23ca13528916e39614b4611799b63943aa1059 /gnu/packages/freedesktop.scm
parentf97cb24967c2787034c3d9a5fce2cf4c1b0c0b3a (diff)
downloadgnu-guix-3f54fd1ea58fc8c21393fac466c0b168016b70db.tar
gnu-guix-3f54fd1ea58fc8c21393fac466c0b168016b70db.tar.gz
gnu: elogind: Return #t from all phases.
* gnu/packages/freedesktop.scm (elogin)[arguments]: Return #t from all phases. Use invoke and remove vestigial plumbing in the 'autogen' phase.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 9c70d906f7..c981271e84 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -275,11 +275,12 @@ the freedesktop.org XDG Base Directory specification.")
;; Fix compilation with glibc >= 2.26, which removed xlocale.h.
;; This can be removed for elogind 234.
(substitute* "src/basic/parse-util.c"
- (("xlocale\\.h") "locale.h"))))
+ (("xlocale\\.h") "locale.h"))
+ #t))
(add-before 'configure 'autogen
(lambda _
- (and (zero? (system* "intltoolize" "--force" "--automake"))
- (zero? (system* "autoreconf" "-vif")))))
+ (invoke "intltoolize" "--force" "--automake")
+ (invoke "autoreconf" "-vif")))
(add-before 'build 'fix-service-file
(lambda* (#:key outputs #:allow-other-keys)
;; Fix the file name of the 'elogind' binary in the D-Bus
@@ -287,7 +288,8 @@ the freedesktop.org XDG Base Directory specification.")
(substitute* "src/login/org.freedesktop.login1.service"
(("^Exec=.*")
(string-append "Exec=" (assoc-ref %outputs "out")
- "/libexec/elogind/elogind\n")))))
+ "/libexec/elogind/elogind\n")))
+ #t))
(add-after 'install 'add-libcap-to-search-path
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Add a missing '-L' for libcap in libelogind.la. See