summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-04-23 13:13:53 -0400
committerMark H Weaver <mhw@netris.org>2016-04-23 13:13:53 -0400
commite969b140a4382fd91514439a57749379cf00f86b (patch)
treec5c5adfc0c7c4cd0c367fa37203637e6d655544c /gnu/packages/fontutils.scm
parent267061ba0bc6df0d61081b97d650d95acec8178a (diff)
downloadgnu-guix-e969b140a4382fd91514439a57749379cf00f86b.tar
gnu-guix-e969b140a4382fd91514439a57749379cf00f86b.tar.gz
Revert "Merge branch 'gnome-updates'"
This reverts commit 63655d459e28b09cd8d58743dae14b3460f6c9da, reversing changes made to 80627f51f0238b9450745f4e642172d059ca5bb5.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 05adc71212..5f6ff15935 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -46,21 +46,23 @@
(define-public freetype
(package
(name "freetype")
- (version "2.6.3")
+ (version "2.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/freetype/freetype-"
version ".tar.bz2"))
(sha256 (base32
- "18k3b026762lmyrxfil5xv8qwnvj7hc12gz9bjqzbb12lmx707ip"))))
+ "0zilx15fwcpa8hmcxpc423jwb8ijw4qpq968kh18akvn4j0znsc4"))))
(build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (propagated-inputs
- ;; These are all in the Requires.private field of freetype2.pc.
- ;; XXX: add harfbuzz.
- `(("libpng" ,libpng)
- ("zlib" ,zlib)))
+ (arguments
+ `(#:phases
+ ;; This should not be necessary; reported upstream as
+ ;; https://savannah.nongnu.org/bugs/index.php?44261
+ (alist-cons-before
+ 'configure 'set-paths
+ (lambda _
+ (setenv "CONFIG_SHELL" (which "bash")))
+ %standard-phases)))
(synopsis "Font rendering library")
(description
"Freetype is a library that can be used by applications to access the
@@ -359,15 +361,16 @@ applications should be.")
(define-public graphite2
(package
(name "graphite2")
- (version "1.3.8")
+ (version "1.3.6")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/silnrsi/graphite/releases/"
- "download/" version "/" name "-" version ".tgz"))
+ (uri (string-append "https://github.com/silnrsi/graphite/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1hlc9j7w7gihy6gvzfa7902pr6yxq1sr1xkp5rwf0p29m2rjagwz"))))
+ "1frd9mjaqzvh9gs74ngc43igi53vzjzlwr5chbrs6ii1hc4aa23s"))))
(build-system cmake-build-system)
(native-inputs
`(("python" ,python-2) ; because of "import imap" in tests