summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-06-11 00:00:07 +0000
committerEfraim Flashner <efraim@flashner.co.il>2017-06-13 22:05:05 +0300
commit5c46c8582f18c80e7628382d91fc604e3bf364fd (patch)
tree88f565860964285939d027730efaaa095209feda /gnu/packages/enlightenment.scm
parent70c90903012cbd6a8f798e7534140b3e71d9e680 (diff)
downloadgnu-guix-5c46c8582f18c80e7628382d91fc604e3bf364fd.tar
gnu-guix-5c46c8582f18c80e7628382d91fc604e3bf364fd.tar.gz
gnu: enlightenment: Fix the inability to switch keyboard layout.
* gnu/packages/enlightenment.scm (enlightenment): Add new 'fix-keyboard' phase. (inputs): Add 'xkeyboard-config'. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 165ca50ce1..6487446336 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 ng0 <ng0@no-reply.pragmatique.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -208,7 +209,19 @@ Libraries with some extra bells and whistles.")
"1xvngjdsa0p901vfhrh2qpa50k32hwwhc8bgi16a9b5d9byzfhvn"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--enable-mount-eeze")))
+ `(#:configure-flags '("--enable-mount-eeze")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-keyboard
+ (lambda _
+ (let ((xkeyboard (assoc-ref %build-inputs "xkeyboard-config")))
+ ;; We need to patch the path to 'base.lst' to be able
+ ;; to switch the keyboard layout in E.
+ (substitute* "src/modules/xkbswitch/e_mod_parse.c"
+ (("/usr/share/X11/xkb/rules/xorg.lst")
+ (string-append xkeyboard
+ "/share/X11/xkb/rules/base.lst")))
+ #t))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
@@ -220,7 +233,8 @@ Libraries with some extra bells and whistles.")
("libxcb" ,libxcb)
("libxext" ,libxext)
("linux-pam" ,linux-pam)
- ("xcb-util-keysyms" ,xcb-util-keysyms)))
+ ("xcb-util-keysyms" ,xcb-util-keysyms)
+ ("xkeyboard-config" ,xkeyboard-config)))
(home-page "https://www.enlightenment.org/about-enlightenment")
(synopsis "Lightweight desktop environment")
(description