aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-20 17:36:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-20 17:36:56 +0100
commit7f69459aca16756f35f08049c64a1bd77d23f33e (patch)
tree1d267fb62feab89de5d97582672540cbaa37392c /gnu/packages/engineering.scm
parent4a82722a658220ec1e10f9f2d5d77407d38db90e (diff)
parentb1989c12501e880afab62d3ff961791906fef350 (diff)
downloadgnu-guix-7f69459aca16756f35f08049c64a1bd77d23f33e.tar
gnu-guix-7f69459aca16756f35f08049c64a1bd77d23f33e.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index cf8df310b0..449584f57e 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1,11 +1,12 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -177,6 +178,13 @@ plans and designs.")
(add-before 'check 'set-home
(lambda _
(setenv "HOME" (getenv "TMPDIR"))
+ #t))
+ ;; FIXME: These two tests fail for unknown reasons. They return "2"
+ ;; when they should return "1".
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "utils/tests/gxyrs/tests.list"
+ (("^do_nothing.*") ""))
#t)))
#:configure-flags
(let ((pcb (assoc-ref %build-inputs "pcb")))
@@ -896,16 +904,16 @@ interface to select the best such procedures to use on a given system.")
(define-public harminv
(package
(name "harminv")
- (version "1.4")
+ (version "1.4.1")
(source (origin
(method url-fetch)
(uri
- (string-append
- "http://ab-initio.mit.edu/harminv/harminv-"
- version ".tar.gz"))
+ (string-append "https://github.com/stevengj/harminv/"
+ "releases/download/v" version "/"
+ name "-" version ".tar.gz"))
(sha256
(base32
- "1pmm8d6fx9ahhnk7w12bfa6zx3afbkg4gkvlvgwhpjxbcrvrp3jk"))))
+ "0w1n4d249vlpda0hi6z1v13qp21vlbp3ykn0m8qg4rd5132j7fg1"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -920,7 +928,7 @@ interface to select the best such procedures to use on a given system.")
`(("fortran" ,gfortran)))
(inputs
`(("lapack" ,lapack)))
- (home-page "http://ab-initio.mit.edu/wiki/index.php/Harminv")
+ (home-page "https://github.com/stevengj/harminv")
(synopsis "Harmonic inversion solver")
(description
"Harminv is a free program (and accompanying library) to solve the problem of