summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
committerMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
commit647888845c0d7b9ea1b51a3e3492d4d2382f4468 (patch)
treebe34c5ec88db452c63253dc4a15f9f4cf199b1e6 /gnu/packages/dns.scm
parentfe15613cdf8623574ce64c05416dd3fab41eef86 (diff)
parentc657716ede8932da356635802534aa13205a6ecd (diff)
downloadgnu-guix-647888845c0d7b9ea1b51a3e3492d4d2382f4468.tar
gnu-guix-647888845c0d7b9ea1b51a3e3492d4d2382f4468.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 735b2af9b4..78f3eff423 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -59,7 +59,7 @@
(define-public dnsmasq
(package
(name "dnsmasq")
- (version "2.78")
+ (version "2.79")
(source (origin
(method url-fetch)
(uri (string-append
@@ -67,7 +67,7 @@
version ".tar.xz"))
(sha256
(base32
- "0ar5h5v3kas2qx2wgy5iqin15gc4jhqrqs067xacgc3lii1rz549"))))
+ "07w6cw706yyahwvbvslhkrbjf2ynv567cgy9pal8bz8lrbsp9bbq"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -79,16 +79,15 @@
#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"CC=gcc"
"COPTS=\"-DHAVE_DBUS\"")
- ;; No 'check' target.
- #:tests? #f))
+ #:tests? #f)) ; no ‘check’ target
(home-page "http://www.thekelleys.org.uk/dnsmasq/doc.html")
(synopsis "Small caching DNS proxy and DHCP/TFTP server")
(description
- "Dnsmasq is a lightweight DNS forwarder and DHCP server. It is designed
-to provide DNS and optionally, DHCP, to a small network. It can serve the
+ "Dnsmasq is a light-weight DNS forwarder and DHCP server. It is designed
+to provide DNS and, optionally, DHCP to a small network. It can serve the
names of local machines which are not in the global DNS. The DHCP server
integrates with the DNS server and allows machines with DHCP-allocated
-addresses to appear in the DNS with names configured either in each host or in
+addresses to appear in the DNS with names configured either on each host or in
a central configuration file. Dnsmasq supports static and dynamic DHCP leases
and BOOTP/TFTP for network booting of diskless machines.")
;; Source files only say GPL2 and GPL3 are allowed.