summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorVijayalakshmi Vedantham <vijimay12@gmail.com>2018-03-29 04:25:43 +0530
committerLudovic Courtès <ludo@gnu.org>2018-04-04 14:39:39 +0200
commit8b209bb6924cbfe3f438f66a6776a2994e0cdeaa (patch)
tree065f8e36eb91ced5808e6ba2650c4467a5e0347c /gnu/packages/django.scm
parentcd730719846538bf04061f85adc1651f8c2a509d (diff)
downloadgnu-guix-8b209bb6924cbfe3f438f66a6776a2994e0cdeaa.tar
gnu-guix-8b209bb6924cbfe3f438f66a6776a2994e0cdeaa.tar.gz
gnu: Add python-django-override-storage.
* gnu/packages/django.scm (python-django-override-storage): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 4bb2e69049..d42afb2285 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -809,3 +810,25 @@ provides features like a web browseable API and authentication policies.")
"@code{django-crispy-forms} lets you easily build, customize and reuse
forms using your favorite CSS framework, without writing template code.")
(license license:expat)))
+
+(define-public python-django-override-storage
+ (package
+ (name "python-django-override-storage")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-override-storage" version))
+ (sha256
+ (base32
+ "0sqz1mh0yn8b1bzz2gr2azfiynljigm5gkzavp5n17zd3j2jg57x"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-django" ,python-django)))
+ (home-page
+ "https://github.com/danifus/django-override-storage")
+ (synopsis "Django test helpers to manage file storage side effects")
+ (description
+ "This project provides tools to help reduce the side effects of using
+FileFields during tests.")
+ (license license:expat)))