summaryrefslogtreecommitdiff
path: root/gnu/packages/ddrescue.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-03 22:12:05 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-03 22:43:00 +0200
commitcc4a2aeb984b8cd007c48a2fb140792ce2a70a56 (patch)
tree50dfae2058133794bf3751489b5f38f142a0b770 /gnu/packages/ddrescue.scm
parenta549ab4bcf5756d10981141720aba782dd5827ad (diff)
downloadgnu-guix-cc4a2aeb984b8cd007c48a2fb140792ce2a70a56.tar
gnu-guix-cc4a2aeb984b8cd007c48a2fb140792ce2a70a56.tar.gz
gnu: Merge Parted, fdisk, and ddrescue in (gnu packages disk).
* gnu/packages/parted.scm: Rename to... * gnu/packages/disk.scm: ... this. New file. Merge with... * gnu/packages/fdisk.scm: ... this; remove file; * gnu/packages/ddrescue.scm: ... and this; remove file. * gnu/system/install.scm, gnu/system/vm.scm: Adjust accordingly. * gnu-system.am (GNU_SYSTEM_MODULES): Remove gnu/packages/{parted,fdisk,ddrescue}.scm and add gnu/packages/disk.scm.
Diffstat (limited to 'gnu/packages/ddrescue.scm')
-rw-r--r--gnu/packages/ddrescue.scm47
1 files changed, 0 insertions, 47 deletions
diff --git a/gnu/packages/ddrescue.scm b/gnu/packages/ddrescue.scm
deleted file mode 100644
index dd5bf0e552..0000000000
--- a/gnu/packages/ddrescue.scm
+++ /dev/null
@@ -1,47 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages ddrescue)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module ((gnu packages compression) #:select (lzip)))
-
-(define-public ddrescue
- (package
- (name "ddrescue")
- (version "1.17")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/ddrescue/ddrescue-"
- version ".tar.lz"))
- (sha256
- (base32
- "0bvmsbzli2j4czwkabzs978n1y6vx31axh02kpgcf7033cc6rydy"))))
- (build-system gnu-build-system)
- (home-page "http://www.gnu.org/software/ddrescue/ddrescue.html")
- (synopsis "Data recovery utility")
- (native-inputs `(("lzip" ,lzip)))
- (description
- "GNU ddrescue is a fully automated data recovery tool. It copies data
-from one file to another, working to rescue data in case of read errors. The
-program also includes a tool for manipulating its log files, which are used
-to recover data more efficiently by only reading the necessary blocks.")
- (license gpl3+)))