summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-15 23:26:39 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-20 20:17:20 +0200
commit7cbf06d8c2935abfc6c688cf3f9b99e0e5393960 (patch)
tree8785a6d1428530f5436f22affbb3ada36d315903 /gnu/packages/databases.scm
parent725449bd7ae6c8882d54fd4e0b6c5b3339b34627 (diff)
downloadgnu-guix-7cbf06d8c2935abfc6c688cf3f9b99e0e5393960.tar
gnu-guix-7cbf06d8c2935abfc6c688cf3f9b99e0e5393960.tar.gz
gnu: mysql: Fix build.
MySQL demands boost@1.59.0, and lying about it no longer works: sql/item_geofunc_internal.cc: In function ‘void handle_gis_exception(const char*)’: sql/item_geofunc_internal.cc:37:81: error: expected unqualified-id before ‘&’ token catch (const boost::geometry::detail::self_get_turn_points::self_ip_exception &) ^ [...] * gnu/packages/databases.scm (boost-for-mysql): New variable. (mysql)[inputs]: Use that instead of the regular boost. [arguments]: Remove now-unnecessary ‘patch-boost-version’ phase.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm27
1 files changed, 17 insertions, 10 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 37fd88f97b..934af5017d 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -548,6 +548,22 @@ RDBMS systems (which are deep in functionality).")
;; Some parts are licensed under the Apache License
license:asl2.0))))
+(define boost-for-mysql
+ (package
+ (inherit boost)
+ (version "1.59.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/boost/boost/" version "/boost_"
+ (string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "1jj1aai5rdmd72g90a3pd8sw9vi32zad46xv5av8fhnr48ir6ykj"))))))
+
+;; XXX When updating, check whether boost-for-mysql is still needed.
+;; It might suffice to patch ‘cmake/boost.cmake’ as done in the past.
(define-public mysql
(package
(name "mysql")
@@ -589,15 +605,6 @@ RDBMS systems (which are deep in functionality).")
"-DINSTALL_SQLBENCHDIR=")
#:phases (modify-phases %standard-phases
(add-after
- 'unpack 'patch-boost-version
- (lambda _
- ;; Mysql wants boost-1.59.0 specifically
- (substitute* "cmake/boost.cmake"
- (("59")
- ,(match (string-split (package-version boost) #\.)
- ((_ minor . _) minor))))
- #t))
- (add-after
'install 'remove-extra-binaries
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -611,7 +618,7 @@ RDBMS systems (which are deep in functionality).")
`(("bison" ,bison)
("perl" ,perl)))
(inputs
- `(("boost" ,boost)
+ `(("boost" ,boost-for-mysql)
("libaio" ,libaio)
("ncurses" ,ncurses)
("openssl" ,openssl)