summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-06 11:47:30 +0200
committerKei Kebreau <kkebreau@posteo.net>2018-06-17 21:59:51 -0400
commit47de00af16168a5ff751cf28ea6e91dd3eb05aa8 (patch)
tree30cb0983d65af20a0df10a620a1effb899ef3f4d /gnu/packages/crypto.scm
parentb4eae997fe5b928f179c34d281e9f2c3eccd3670 (diff)
downloadgnu-guix-47de00af16168a5ff751cf28ea6e91dd3eb05aa8.tar
gnu-guix-47de00af16168a5ff751cf28ea6e91dd3eb05aa8.tar.gz
gnu: encfs: Update to 1.9.5.
* gnu/packages/crypto.scm (encfs): Update to 1.9.5. [source](snippet): Adjust paths. Remove two bundled libraries. [native-inputs]: Add googletest-source. [arguments]: Add 'unpack-googletest' and 'make-unittests' phases. Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 105760afa3..338db04f53 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cryptsetup)
#:use-module (gnu packages databases)
@@ -217,7 +218,7 @@ communication.")
(define-public encfs
(package
(name "encfs")
- (version "1.9.1")
+ (version "1.9.5")
(source
(origin
(method url-fetch)
@@ -226,13 +227,13 @@ communication.")
version "/encfs-" version ".tar.gz"))
(sha256
(base32
- "1906254dg5hwljh0h4gyrw09ms3b57dlhjfzhfzffv50yzpkl837"))
+ "0qzxavvv20577bxvly8s7d3y7bqasqclc2mllp0ddfncjm9z02a7"))
(modules '((guix build utils)))
;; Remove bundled dependencies in favour of proper inputs.
(snippet '(begin
(for-each delete-file-recursively
- (find-files "internal" "^tinyxml2-[0-9]"
- #:directories? #t))
+ '("vendor/github.com/leethomason/tinyxml2"
+ "vendor/github.com/google/googletest"))
#t))))
(build-system cmake-build-system)
(native-inputs
@@ -240,6 +241,7 @@ communication.")
;; Test dependencies.
("expect" ,expect)
+ ("googletest-source" ,(package-source googletest))
("perl" ,perl)))
(inputs
`(("attr" ,attr)
@@ -247,7 +249,18 @@ communication.")
("openssl" ,openssl)
("tinyxml2" ,tinyxml2)))
(arguments
- `(#:configure-flags (list "-DUSE_INTERNAL_TINYXML=OFF")))
+ `(#:configure-flags (list "-DUSE_INTERNAL_TINYXML=OFF")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-googletest
+ (lambda* (#:key inputs #:allow-other-keys)
+ (mkdir-p "vendor/github.com/google/googletest")
+ (invoke "tar" "xvf" (assoc-ref inputs "googletest-source")
+ "-C" "vendor/github.com/google/googletest"
+ "--strip-components=1")))
+ (add-before 'check 'make-unittests
+ (lambda _
+ (invoke "make" "unittests"))))))
(home-page "https://vgough.github.io/encfs")
(synopsis "Encrypted virtual file system")
(description