summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-02-10 17:40:25 +0100
committerLudovic Courtès <ludo@gnu.org>2017-02-10 17:40:25 +0100
commit768f0ac9dd9993827430d62d0f72a5020f476892 (patch)
tree600f7ca7cedb221147edfc92356e11bc6c56f311 /gnu/packages/compression.scm
parent955ba55c6bf3a22264b56274ec22cad1551c1ce6 (diff)
parent49dbae548e92e0521ae125239282a04d8ea924cf (diff)
downloadgnu-guix-768f0ac9dd9993827430d62d0f72a5020f476892.tar
gnu-guix-768f0ac9dd9993827430d62d0f72a5020f476892.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm76
1 files changed, 72 insertions, 4 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index e0eca4ef9f..81e95c70e5 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
@@ -45,6 +47,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages valgrind)
#:use-module (ice-9 match)
#:use-module ((srfi srfi-1) #:select (last)))
@@ -362,6 +365,44 @@ LZO is written in ANSI C. Both the source code and the compressed data
format are designed to be portable across platforms.")
(license license:gpl2+)))
+(define-public python-lzo
+ (package
+ (name "python-lzo")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-lzo" version))
+ (sha256
+ (base32
+ "11p3ifg14p086byhhin6azx5svlkg8dzw2b5abixik97xd6fm81q"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "check"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setuppy
+ (lambda _
+ (substitute* "setup.py"
+ (("include_dirs.append\\(.*\\)")
+ (string-append "include_dirs.append('"
+ (assoc-ref %build-inputs "lzo")
+ "/include/lzo"
+ "')")))
+ #t)))))
+ (inputs
+ `(("lzo" ,lzo)))
+ (home-page "https://github.com/jd-boyd/python-lzo")
+ (synopsis "Python bindings for the LZO data compression library")
+ (description
+ "Python-LZO provides Python bindings for LZO, i.e. you can access
+the LZO library from your Python scripts thereby compressing ordinary
+Python strings.")
+ (license license:gpl2+)))
+
+(define-public python2-lzo
+ (package-with-python2 python-lzo))
+
(define-public lzop
(package
(name "lzop")
@@ -633,6 +674,31 @@ time for compression ratio.")
;; line interface programs (lz4, fullbench, fuzzer, datagen) are GPL2+.
(license (list license:bsd-2 license:gpl2+))))
+(define-public python-lz4
+ (package
+ (name "python-lz4")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lz4" version))
+ (sha256
+ (base32
+ "1irad4sq4hdr30fr53smvv3zzk4rddcf9b4jx19w8s9xsxhr1x3b"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/python-lz4/python-lz4")
+ (synopsis "LZ4 Bindings for Python")
+ (description
+ "This package provides python bindings for the lz4 compression library
+by Yann Collet. The project contains bindings for the LZ4 block format and
+the LZ4 frame format.")
+ (license license:bsd-3)))
+
+(define-public python2-lz4
+ (package-with-python2 python-lz4))
+
(define-public squashfs-tools
(package
(name "squashfs-tools")
@@ -924,7 +990,8 @@ for most inputs, but the resulting compressed files are anywhere from 20% to
(delete-file-recursively "CPP/7zip/Archive/Rar")
(delete-file-recursively "CPP/7zip/Compress/Rar")
#t))
- (patches (search-patches "p7zip-remove-unused-code.patch"))))
+ (patches (search-patches "p7zip-CVE-2016-9296.patch"
+ "p7zip-remove-unused-code.patch"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -1034,11 +1101,12 @@ functionality in a C++ iostream.")
(_ " -DNOJIT")))
;; These should be safe, lowest-common-denominator instruction sets,
;; allowing for some optimisation while remaining reproducible.
- (string-append "CXXFLAGS=-O3 -mtune=generic -DNDEBUG"
+ (string-append "CXXFLAGS=-O3 -DNDEBUG"
,(match (or (%current-target-system)
(%current-system))
- ("x86_64-linux" " -march=nocona")
- ("i686-linux" " -march=i686")
+ ("x86_64-linux" " -march=nocona -mtune=generic")
+ ("i686-linux" " -march=i686 -mtune=generic")
+ ("armhf-linux" " -mtune=generic-armv7-a")
(_ "")))
(string-append "PREFIX="
(assoc-ref %outputs "out")))))