summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2018-04-08 16:51:42 -0700
committerChris Marusich <cmmarusich@gmail.com>2018-05-08 21:55:46 -0700
commitede121de426f9c56820852888a0b370f0ccbce49 (patch)
treecddd5c464c259d03dd97a021922950f161cfcb13 /gnu/packages/commencement.scm
parentb61cb24492c150b5eebb5227f2a7c32e4d42e1d4 (diff)
downloadgnu-guix-ede121de426f9c56820852888a0b370f0ccbce49.tar
gnu-guix-ede121de426f9c56820852888a0b370f0ccbce49.tar.gz
guix: Separate the package name and version with "@", not "-".
* guix/packages.scm (package-full-name): By default, use "@" to separate the package name and package version. Add an optional delimiter argument so that there is still a way to explicitly use a different delimiter. * gnu/packages/commencement.scm (gcc-boot0) <unpack-gmp&co>: Adjust accordingly. * tests/graph.scm: Adjust accordingly. * tests/profiles.scm: Adjust accordingly. * NEWS: Mention the change. Fixes: <https://bugs.gnu.org/31088>. Reported by Pierre Neidhardt <ambrevar@gmail.com>.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 1026ee8929..2791409bf9 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -282,7 +282,7 @@
;; Drop trailing letters, as gmp-6.0.0a unpacks
;; into gmp-6.0.0.
`(symlink ,(string-trim-right
- (package-full-name lib)
+ (package-full-name lib "-")
char-set:letter)
,(package-name lib)))
(list gmp-6.0 mpfr mpc))))