summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2017-02-28 18:50:07 +0100
committerJohn Darrington <jmd@gnu.org>2017-02-28 18:55:11 +0100
commita9406b2416314fa7a52fa6e9b1b14faf4567b80e (patch)
treef6577a08aed54f81c2906f5924f1f30793b9621c /gnu/packages/cdrom.scm
parentb02a141f3e714ac70173ecbf14afe97b9a62eb2f (diff)
downloadgnu-guix-a9406b2416314fa7a52fa6e9b1b14faf4567b80e.tar
gnu-guix-a9406b2416314fa7a52fa6e9b1b14faf4567b80e.tar.gz
gnu: Add ccd2cue
* gnu/packages/cdrom.scm (ccd2cue): New variable.
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 293bf16ade..14e430646a 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 John Darrington <jmd@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -496,3 +497,27 @@ session, and it can create M3U playlists.")
(synopsis "Command-line program to extract audio CDs")
(description "RipIT is used to extract audio from CDs.")
(license gpl2)))
+
+(define-public ccd2cue
+ (package
+ (name "ccd2cue")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnu/ccd2cue/ccd2cue-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1icrkg25hwx4gsn3dski2172ia4ywjh8m1sa17zmjclnrgdwy9c7"))))
+ (build-system gnu-build-system)
+ (synopsis "CCD to CUE sheet conversion")
+ (description
+ "GNU ccd2cue is a preprocessor for CD burning software that allows
+the conversion of the proprietary CCD format to the CUE format, which
+is well-supported by free software. These files are commonly
+distributed with CD images and are used to describe how tracks are
+laid out on the image.")
+ (home-page "http://www.gnu.org/software/ccd2cue")
+ (license gpl3+)))