summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-05-02 17:53:40 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-05-02 17:53:40 +0200
commitc3052d6bcd2193b258fb92b99291a4918931fe36 (patch)
tree0e0cbbc019e68f4f1c865b4d2f5e341eb45d96ee /gnu/packages/bootstrap.scm
parent0bfb9b439953b755a510974e51e651f79526a5a4 (diff)
parentb74f64a960542b0679ab13de0dd28adc496cf084 (diff)
downloadgnu-guix-c3052d6bcd2193b258fb92b99291a4918931fe36.tar
gnu-guix-c3052d6bcd2193b258fb92b99291a4918931fe36.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 2cd8534ace..2aa4711ba8 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -125,7 +125,7 @@ successful, or false to signal an error."
("tarball" ,(bootstrap-origin (source (%current-system))))))
(source #f)
(synopsis description)
- (description #f)
+ (description description)
(home-page #f)
(license gpl3+)))
@@ -166,11 +166,13 @@ successful, or false to signal an error."
((string=? system "mips64el-linux") "/lib/ld.so.1")
((string=? system "i586-gnu") "/lib/ld.so.1")
((string=? system "i686-gnu") "/lib/ld.so.1")
+ ((string=? system "aarch64-linux") "/lib/ld-linux-aarch64.so.1")
;; XXX: This one is used bare-bones, without a libc, so add a case
;; here just so we can keep going.
((string=? system "xtensa-elf") "no-ld.so")
((string=? system "avr") "no-ld.so")
+ ((string=? system "i686-mingw") "no-ld.so")
(else (error "dynamic linker name not known for this system"
system))))
@@ -410,7 +412,7 @@ $out/bin/guile --version~%"
(base32
"0k97a3whzx3apsi9n2cbsrr79ad6lh00klxph9hw4fqyp1abkdsg")))))))))
(synopsis "Bootstrap binaries and headers of the GNU C Library")
- (description #f)
+ (description synopsis)
(home-page #f)
(license lgpl2.1+)))
@@ -495,7 +497,7 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
(synopsis "Bootstrap binaries of the GNU Compiler Collection")
- (description #f)
+ (description synopsis)
(home-page #f)
(license gpl3+)))