summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authormephi42 <mephi42@gmail.com>2018-02-16 17:50:42 +0300
committerLudovic Courtès <ludo@gnu.org>2018-02-19 22:22:21 +0100
commitb91004c2f5b95281e4533195108051aeeecf99a3 (patch)
tree2eda15335c76f3c439cc214c2ae6e7ce6546b6aa /gnu/packages/bootstrap.scm
parent900be977ae9c2413bad071458afe500b3cb96cd4 (diff)
downloadgnu-guix-b91004c2f5b95281e4533195108051aeeecf99a3.tar
gnu-guix-b91004c2f5b95281e4533195108051aeeecf99a3.tar.gz
gnu: Add basic support for s390x-linux-gnu targets.
* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add "s390x-linux". * gnu/packages/linux.scm (system->linux-architecture): Add "s390" prefix. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index b02737cb7c..27f2053c43 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -177,6 +177,7 @@ successful, or false to signal an error."
((string=? system "powerpc-linux") "/lib/ld.so.1")
((string=? system "powerpc64le-linux") "/lib/ld64.so.2")
((string=? system "alpha-linux") "/lib/ld-linux.so.2")
+ ((string=? system "s390x-linux") "/lib/ld64.so.1")
;; XXX: This one is used bare-bones, without a libc, so add a case
;; here just so we can keep going.