summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-01-29 10:35:52 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-01-30 10:45:27 +0100
commit241e122193e6eee900cab1f3a1caec2f90603560 (patch)
tree728f0046a3d103ea7abd9739bc16b2326d68b190 /gnu/packages/bioinformatics.scm
parente89fa047f76048ac907756a5f08ddc06c84c6c40 (diff)
downloadgnu-guix-241e122193e6eee900cab1f3a1caec2f90603560.tar
gnu-guix-241e122193e6eee900cab1f3a1caec2f90603560.tar.gz
gnu: bowtie: fix build errors
* gnu/packages/bioinformatics.scm (bowtie): Add 'supported-systems' field and add Makefile patch. * gnu/packages/patches/bowtie-fix-makefile.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ff6c3379af..620c8090b7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -95,7 +95,8 @@ BED, GFF/GTF, VCF.")
(("^CPP = .*$") "CPP = g++")
;; replace BUILD_HOST and BUILD_TIME for deterministic build
(("-DBUILD_HOST=.*") "-DBUILD_HOST=\"\\\"guix\\\"\"")
- (("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))))
+ (("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))
+ (patches (list (search-patch "bowtie-fix-makefile.patch")))))
(build-system gnu-build-system)
(inputs `(("perl" ,perl)
("perl-clone" ,perl-clone)
@@ -133,6 +134,7 @@ aligning to relatively long (e.g. mammalian) genomes. Bowtie 2 indexes the
genome with an FM Index to keep its memory footprint small: for the human
genome, its memory footprint is typically around 3.2 GB. Bowtie 2 supports
gapped, local, and paired-end alignment modes.")
+ (supported-systems '("x86_64-linux"))
(license license:gpl3+)))
(define-public samtools