summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-07-04 17:43:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-05 15:08:44 +0200
commit2cc511083239d5579aafef6a9dea03f36a1c1b2b (patch)
tree03321b8a4b095935517f5149b17b560f648345a4 /gnu/packages/bioconductor.scm
parentfa6975996384c8ae1287f8673a59bda3d86a1532 (diff)
downloadgnu-guix-2cc511083239d5579aafef6a9dea03f36a1c1b2b.tar
gnu-guix-2cc511083239d5579aafef6a9dea03f36a1c1b2b.tar.gz
gnu: Add r-genelendatabase.
* gnu/packages/bioconductor.scm (r-genelendatabase): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a6a8216ccb..5e08143f30 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -167,6 +167,35 @@ Repeats Finder (TRF mask). Only the AGAPS and AMB masks are \"active\" by
default." )
(license license:artistic2.0)))
+(define-public r-genelendatabase
+ (package
+ (name "r-genelendatabase")
+ (version "1.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/experiment/" instead of "bioc/".
+ (uri (string-append "https://bioconductor.org/packages/"
+ "release/data/experiment/src/contrib"
+ "/geneLenDataBase_" version ".tar.gz"))
+ (sha256
+ (base32
+ "07mmmn53kb7v14msc13dsbm8ghssbvwcrhifrk15hn37bw2p4ja5"))))
+ (properties
+ `((upstream-name . "geneLenDataBase")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rtracklayer" ,r-rtracklayer)
+ ("r-genomicfeatures" ,r-genomicfeatures)))
+ (home-page "https://bioconductor.org/packages/geneLenDataBase/")
+ (synopsis "Lengths of mRNA transcripts for a number of genomes")
+ (description
+ "This package provides the lengths of mRNA transcripts for a number of
+genomes and gene ID formats, largely based on the UCSC table browser.")
+ (license license:lgpl2.0+)))
+
+
(define-public r-hpar
(package
(name "r-hpar")