summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-01 15:48:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-01 15:48:26 +0200
commitae66fdaf9f7971c0a1b33d0c20844e903ccd909c (patch)
tree579da92220474acfcd5c7ebc25d9e85916b4da3c /gnu/packages/base.scm
parent2207053542f293980266ab77c920fcd8de2f961b (diff)
downloadgnu-guix-ae66fdaf9f7971c0a1b33d0c20844e903ccd909c.tar
gnu-guix-ae66fdaf9f7971c0a1b33d0c20844e903ccd909c.tar.gz
gnu: Add glibc@2.28.
* gnu/packages/base.scm (glibc-2.28): New public variable.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index de0aa92adb..4065af0abc 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -873,6 +873,23 @@ GLIBC/HURD for a Hurd host"
(define-syntax glibc
(identifier-syntax (glibc-for-target)))
+;; The "next" libc. Useful for populating locale data before reconfiguring the
+;; entire system on it. Will be the default in the next rebuild cycle.
+(define-public glibc-2.28
+ (package
+ (inherit glibc)
+ (version "2.28")
+ (source (origin
+ (inherit (package-source glibc))
+ (uri (string-append "mirror://gnu/glibc/glibc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "10iha5ynvdj5m62vgpgqbq4cwvc2yhyl2w9yyyjgfxmdmx8h145i"))
+ (patches (search-patches "glibc-allow-kernel-2.6.32.patch"
+ "glibc-ldd-x86_64.patch"
+ "glibc-hidden-visibility-ldconfig.patch"
+ "glibc-versioned-locpath.patch"))))))
+
;; Below are old libc versions, which we use mostly to build locale data in
;; the old format (which the new libc cannot cope with.)