summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 02:19:15 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 02:45:17 +0100
commitfbf210cb246f61f24bef1e0220a50f832466139b (patch)
treea0bae383854071b88846888e15978475e6e7fa35 /gnu/packages/backup.scm
parent8fc46a43c02c5d911840c8acc7850070613fc01a (diff)
downloadgnu-guix-fbf210cb246f61f24bef1e0220a50f832466139b.tar
gnu-guix-fbf210cb246f61f24bef1e0220a50f832466139b.tar.gz
gnu: rdup: Update to 1.1.15.
* gnu/packages/backup.scm (rdup): Update to 1.1.15. [source]: Use new URI. Remove snippet. [native-inputs]: Add autoconf and automake. [inputs]: Add mcrypt. [arguments]: Add ‘bootstrap’ and ‘qualify-inputs’ phases. Remove ‘remove-Werror’ phase. [home-page]: Use apparent new (and HTTPS) home page.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm50
1 files changed, 24 insertions, 26 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index cfeaa207be..7302406c57 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -264,49 +264,47 @@ random access nor for in-place modification.")
(define-public rdup
(package
(name "rdup")
- (version "1.1.14")
+ (version "1.1.15")
(source
(origin
(method url-fetch)
- (uri (string-append "http://archive.miek.nl/projects/rdup/rdup-"
- version ".tar.bz2"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (uri (string-append "https://github.com/miekg/rdup/archive/"
+ version ".tar.gz"))
(sha256
(base32
- "0aklwd9v7ix0m4ayl762sil685f42cwljzx3jz5skrnjaq32npmj"))
- (modules '((guix build utils)))
- (snippet
- ;; Some test scripts are missing shebangs, which cause "could not
- ;; execute" errors. Add shebangs.
- '(for-each
- (lambda (testscript)
- (with-atomic-file-replacement
- (string-append "testsuite/rdup/" testscript)
- (lambda (in out)
- (begin
- (format out "#!/bin/sh\n" )
- (dump-port in out)))))
- '("rdup.hardlink.helper"
- "rdup.hardlink-strip.helper"
- "rdup.hardlink-strip2.helper"
- "rdup.pipeline.helper")))))
+ "1jr91hgcf0rrpanqlwws72ql9db6d6grs2i122ki1s4bx0vqqyvq"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+
+ ;; For tests.
("dejagnu" ,dejagnu)))
(inputs
`(("glib" ,glib)
("pcre" ,pcre)
("libarchive" ,libarchive)
+ ("mcrypt" ,mcrypt)
("nettle" ,nettle)))
(arguments
`(#:parallel-build? #f ;race conditions
#:phases
(modify-phases %standard-phases
- (add-before 'build 'remove-Werror
- ;; rdup uses a deprecated function from libarchive
+ (add-after 'unpack 'bootstrap
(lambda _
- (substitute* "GNUmakefile"
- (("^(CFLAGS=.*)-Werror" _ front) front))
+ (invoke "autoreconf")))
+ (add-before 'build 'qualify-inputs
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; This script is full of pitfalls. Fix some that particularly
+ ;; affect Guix users & leave the rest as reader excercises.
+ (substitute* "rdup-simple"
+ ;; Use the input ‘mcrypt’, not whatever's in $PATH at run time.
+ (("([' ])mcrypt " all delimiter)
+ (string-append delimiter (which "mcrypt") " "))
+ ;; Avoid frivolous dependency on ‘which’ with a shell builtin.
+ (("which") "command -v"))
#t))
(add-before 'check 'pre-check
(lambda _
@@ -314,7 +312,7 @@ random access nor for in-place modification.")
(substitute* "testsuite/rdup/rdup.rdup-up-t-with-file.exp"
(("/bin/cat") (which "cat")))
#t)))))
- (home-page "http://archive.miek.nl/projects/rdup/index.html")
+ (home-page "https://github.com/miekg/rdup")
(synopsis "Provide a list of files to backup")
(description
"Rdup is a utility inspired by rsync and the plan9 way of doing backups.