summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-17 22:57:52 -0400
committerLeo Famulari <leo@famulari.name>2016-10-19 16:00:26 -0400
commitc21b1a1fbb8c1b776cf831d24dfb1a742a4ded70 (patch)
tree383b417f219cc69509e2cd2b76ff44847cc7640a /gnu/packages/backup.scm
parentb332c823b78e61f2472309fa706d7609cbc9ef11 (diff)
downloadgnu-guix-c21b1a1fbb8c1b776cf831d24dfb1a742a4ded70.tar
gnu-guix-c21b1a1fbb8c1b776cf831d24dfb1a742a4ded70.tar.gz
gnu: borg: Install more documentation.
* gnu/packages/backup.scm (borg)[arguments]: Install more documentation in 'install-doc' phase. Use (srfi srfi-26).
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 797c06e149..81925ab3ef 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -426,7 +426,10 @@ detection, and lossless compression.")
delete-file (find-files "borg" "^(c|h|p).*\\.c$")))))
(build-system python-build-system)
(arguments
- `(#:phases
+ `(#:modules ((srfi srfi-26) ; for cut
+ (guix build utils)
+ (guix build python-build-system))
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-env
(lambda* (#:key inputs #:allow-other-keys)
@@ -439,7 +442,12 @@ detection, and lossless compression.")
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (man (string-append out "/share/man/man1")))
+ (man (string-append out "/share/man/man1"))
+ (misc (string-append out "/share/borg/misc")))
+ (for-each (cut install-file <> misc)
+ '("docs/misc/create_chunker-params.txt"
+ "docs/misc/internals-picture.txt"
+ "docs/misc/prune-example.txt"))
(and
(zero? (system* "python3" "setup.py" "build_ext" "--inplace"))
(zero? (system* "make" "-C" "docs" "man"))