summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-10 15:32:51 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-10 15:32:51 +0200
commit7b38f045c04fe69001ff5c2f04486cc51a69ae82 (patch)
treebd839f1f635dc114c84d67c1db09b74f613ec315 /gnu/packages/backup.scm
parent369d15674c8bb251c45a45466031a2da1640df9f (diff)
parent256d5c6e339d59287284bb83f35c594f13bd08f9 (diff)
downloadgnu-guix-7b38f045c04fe69001ff5c2f04486cc51a69ae82.tar
gnu-guix-7b38f045c04fe69001ff5c2f04486cc51a69ae82.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index f55dd1a139..ca880d6c05 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -875,6 +875,15 @@ is like a time machine for your data. ")
,version)
(invoke "go" "run" "build.go"))))
+ (replace 'check
+ (lambda _
+ (with-directory-excursion (string-append
+ "src/github.com/restic/restic-"
+ ,version)
+ ;; unexpected error: fusermount: exit status 1
+ (delete-file "cmd/restic/integration_fuse_test.go")
+ (invoke "go" "run" "build.go" "--test"))))
+
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))