summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-01-23 19:21:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-01-23 19:35:31 +0100
commit2903ee1ea51fffa4e62d18d9f6807c8956fc4c8d (patch)
treeadaa35e3b470a9f176a111ef84fb58f5938c4549 /gnu/packages/backup.scm
parent82110ef658375fd1e8d470ddb7b5e1c5aa116fad (diff)
downloadgnu-guix-2903ee1ea51fffa4e62d18d9f6807c8956fc4c8d.tar
gnu-guix-2903ee1ea51fffa4e62d18d9f6807c8956fc4c8d.tar.gz
gnu: duplicity: Update to 0.7.11.
* gnu/packages/backup.scm (duplicity): Update to 0.7.11. [source]: Remove patches. [inputs]: Add lftp, update gnupg, remove python-2, make python2-lockfile a propagated input, make python2-mock a native-input. [propagated-inputs]: Add python2-lockfile, python2-urllib3. [native-inputs]: Add python2-pexpect, python2-mock. [arguments]: Add build phase to embed gnupg store name. * gnu/packages/patches/duplicity-piped-password.patch: Delete it. * gnu/packages/patches/duplicity-test_selection-tmp.patch: Delete it. * gnu/local.mk (dist_patch_DATA): Remove patches. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm28
1 files changed, 18 insertions, 10 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 8cfe470ec6..8dbe32ebdd 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -34,6 +34,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
#:use-module (gnu packages dejagnu)
+ #:use-module (gnu packages ftp)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
@@ -52,7 +53,7 @@
(define-public duplicity
(package
(name "duplicity")
- (version "0.6.26")
+ (version "0.7.11")
(source
(origin
(method url-fetch)
@@ -62,18 +63,19 @@
version ".tar.gz"))
(sha256
(base32
- "0jh79syhr8n3l81jxlwsmwm1pklb4d923m2lgqbswyavh1fqmvwb"))
- (patches (search-patches "duplicity-piped-password.patch"
- "duplicity-test_selection-tmp.patch"))))
+ "01zcq9cwn4pvj68rihgjvcdgccnxvz4jrba38sbv6nqz19cs2ixh"))))
(build-system python-build-system)
(native-inputs
- `(("util-linux" ,util-linux))) ;setsid command, for the tests
+ `(("util-linux" ,util-linux) ;setsid command, for the tests
+ ("python-pexpect" ,python2-pexpect)
+ ("mock" ,python2-mock)))
+ (propagated-inputs
+ `(("lockfile" ,python2-lockfile)
+ ("urllib3" ,python2-urllib3)))
(inputs
- `(("python" ,python-2)
- ("librsync" ,librsync)
- ("mock" ,python2-mock) ;for testing
- ("lockfile" ,python2-lockfile)
- ("gnupg" ,gnupg-1) ;gpg executable needed
+ `(("librsync" ,librsync)
+ ("lftp" ,lftp)
+ ("gnupg" ,gnupg) ;gpg executable needed
("util-linux" ,util-linux) ;for setsid
("tzdata" ,tzdata)))
(arguments
@@ -81,6 +83,12 @@
#:test-target "test"
#:phases
(modify-phases %standard-phases
+ (add-before
+ 'build 'patch-source ; embed gpg store name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "duplicity/gpginterface.py"
+ (("self.call = 'gpg'")
+ (string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))))
(add-before 'check 'check-setup
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "testing/functional/__init__.py"