summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-08-30 19:28:48 +0200
committerJohn Darrington <jmd@gnu.org>2016-08-31 06:16:54 +0200
commit82e4557d5650b99192bef55b8c518e6444816282 (patch)
tree6412bcea70744204473cac543e00751965a85f56 /gnu/packages/astronomy.scm
parent7a3f94054152777c5cdf50771febc6bfbc54a3fd (diff)
downloadgnu-guix-82e4557d5650b99192bef55b8c518e6444816282.tar
gnu-guix-82e4557d5650b99192bef55b8c518e6444816282.tar.gz
gnu: Add cfitsio
* gnu/packages/astronomy.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
new file mode 100644
index 0000000000..ba1556882d
--- /dev/null
+++ b/gnu/packages/astronomy.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 John Darrington <jmd@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages astronomy)
+ #:use-module (guix packages)
+ #:use-module (guix licenses)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public cfitsio
+ (package
+ (name "cfitsio")
+ (version "3390")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/" name version
+ ".tar.gz"))
+ (sha256
+ (base32 "02gllydm63irwbqqisa3mrskw1fphm5rlplglz3mq9whi3rxilv2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda _
+ (substitute* "Makefile.in" (("/bin/") "")))))))
+ (home-page "http://heasarc.gsfc.nasa.gov/fitsio/fitsio.html")
+ (synopsis "Library for reading and writing FITS files")
+ (description "CFITSIO provides simple high-level routines for reading and
+writing FITS (Flexible Image Transport System) files that insulate the
+programmer from the internal complexities of the FITS format. CFITSIO also
+provides many advanced features for manipulating and filtering the information
+in FITS files.")
+ (license (license:non-copyleft "file://License.txt"
+ "See License.txt in the distribution."))))