summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-10-19 23:12:53 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-10-20 02:16:52 +0200
commit378140e591170a369a03641e095cf7e0e11def79 (patch)
treec2a6ca58c7b0cdeb8b6a3fef458830c7bc72d0a1 /gnu/packages/admin.scm
parent1e9433cf4de46ec1842fba772506973f18d6d1d1 (diff)
downloadgnu-guix-378140e591170a369a03641e095cf7e0e11def79.tar
gnu-guix-378140e591170a369a03641e095cf7e0e11def79.tar.gz
gnu: neofetch: Update to 3.3.0.
* gnu/packages/admin.scm (neofetch): Update to 3.3.0. [arguments]: Add ‘install’ phase replacement that manually invokes make.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 23024fc363..265ca63213 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2139,7 +2139,7 @@ tool for remote execution and deployment.")
(define-public neofetch
(package
(name "neofetch")
- (version "3.2.0")
+ (version "3.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/dylanaraps/neofetch/"
@@ -2147,10 +2147,10 @@ tool for remote execution and deployment.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "07a32rzmch51znxspzyc7zyaldmr383v70b49wmnjdjs2qfdbv3a"))))
+ "15p69q0jchfms1fpb4i7kq8b28w2xpgh2zmynln618qxv1myf228"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; there are no tests
+ `(#:tests? #f ; there are no tests
#:make-flags
(list (string-append "PREFIX=" %output))
#:phases
@@ -2167,7 +2167,15 @@ tool for remote execution and deployment.")
(("\"/usr/share/neofetch")
(string-append "\"" out "/share/neofetch"))))
#t))
- (delete 'configure))))
+ (delete 'configure) ; no configure script
+ (replace 'install
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version))
+ (etc (string-append doc "/examples/etc")))
+ (zero? (apply system* `("make" ,@make-flags
+ ,(string-append "SYSCONFDIR=" etc)
+ "install")))))))))
(home-page "https://github.com/dylanaraps/neofetch")
(synopsis "System info script")
(description "Neofetch is a CLI system information tool written in Bash.