summaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-06-15 21:17:06 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-06-16 21:23:11 +0300
commitbba0fa2499eefab02cacfed9958dc498abfd484d (patch)
tree9db7e8eb5e414b26cfc1db5cb162296200efacf4 /etc
parent806f599c5bc630362359809e66ee8d6f275580c3 (diff)
downloadgnu-guix-bba0fa2499eefab02cacfed9958dc498abfd484d.tar
gnu-guix-bba0fa2499eefab02cacfed9958dc498abfd484d.tar.gz
Add guix-daemon Bash completion file.
* etc/completion/bash/guix-daemon: New file. * Makefile.am (dist_bashcompletion_DATA): Add this.
Diffstat (limited to 'etc')
-rw-r--r--etc/completion/bash/guix-daemon30
1 files changed, 30 insertions, 0 deletions
diff --git a/etc/completion/bash/guix-daemon b/etc/completion/bash/guix-daemon
new file mode 100644
index 0000000000..997c142c7e
--- /dev/null
+++ b/etc/completion/bash/guix-daemon
@@ -0,0 +1,30 @@
+# GNU Guix --- Functional package management for GNU
+# Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+#
+# This file is part of GNU Guix.
+#
+# GNU Guix is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+#
+# GNU Guix is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+# Bash completion for guix-daemon command.
+
+_guix_daemon_complete ()
+{
+ local options="$(${COMP_WORDS[0]} --help 2> /dev/null \
+ | grep '^ \+-' \
+ | sed -e's/^.*--\([a-zA-Z0-9_-]\+\)\(=\?\).*/--\1\2/g')"
+ compopt -o nospace
+ COMPREPLY=($(compgen -W "$options" -- "${COMP_WORDS[${#COMP_WORDS[*]} - 1]}"))
+}
+
+complete -F _guix_daemon_complete guix-daemon