summaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-05 14:33:13 -0500
committerLeo Famulari <leo@famulari.name>2017-03-06 13:25:51 -0500
commit613d0895b92c677e0639d5e77c55043e38e020c8 (patch)
tree5f2600f6c1fdf0648d310d7198772a34b5286c8a /etc
parentb812da70594f5d40647d156f69be0eb169d6be19 (diff)
downloadgnu-guix-613d0895b92c677e0639d5e77c55043e38e020c8.tar
gnu-guix-613d0895b92c677e0639d5e77c55043e38e020c8.tar.gz
build: Don't embed absolute paths in .service and .conf service files.
Otherwise, users will be stuck running an old copy of guix and the guix-daemon if they copy the service files instead of symlinking them. * etc/guix-daemon.conf.in, etc/guix-daemon.service.in, etc/guix-publish.conf.in, etc/guix-publish.service.in: Expand @localstatedir@ instead of @bindir@. * nix/local.mk (etc/guix-%.service, etc/guix-%.conf): Use @localstatedir@ instead of @bindir@.
Diffstat (limited to 'etc')
-rw-r--r--etc/guix-daemon.conf.in2
-rw-r--r--etc/guix-daemon.service.in2
-rw-r--r--etc/guix-publish.conf.in2
-rw-r--r--etc/guix-publish.service.in2
4 files changed, 4 insertions, 4 deletions
diff --git a/etc/guix-daemon.conf.in b/etc/guix-daemon.conf.in
index 8f833cb693..09c70cde38 100644
--- a/etc/guix-daemon.conf.in
+++ b/etc/guix-daemon.conf.in
@@ -9,4 +9,4 @@ stop on runlevel [016]
task
-exec @bindir@/guix-daemon --build-users-group=guixbuild
+exec @localstatedir@/guix/profiles/per-user/root/guix-profile/bin/guix-daemon --build-users-group=guixbuild
diff --git a/etc/guix-daemon.service.in b/etc/guix-daemon.service.in
index ab0ce090c3..ffe4cf9bd5 100644
--- a/etc/guix-daemon.service.in
+++ b/etc/guix-daemon.service.in
@@ -6,7 +6,7 @@
Description=Build daemon for GNU Guix
[Service]
-ExecStart=@bindir@/guix-daemon --build-users-group=guixbuild
+ExecStart=@localstatedir@/guix/profiles/per-user/root/guix-profile/bin/guix-daemon --build-users-group=guixbuild
Environment=GUIX_LOCPATH=/root/.guix-profile/lib/locale
RemainAfterExit=yes
StandardOutput=syslog
diff --git a/etc/guix-publish.conf.in b/etc/guix-publish.conf.in
index 498fa295be..241c594559 100644
--- a/etc/guix-publish.conf.in
+++ b/etc/guix-publish.conf.in
@@ -9,4 +9,4 @@ stop on runlevel [016]
task
-exec @bindir@/guix publish --user=nobody --port=8181
+exec @localstatedir@/guix/profiles/per-user/root/guix-profile/bin/guix publish --user=nobody --port=8181
diff --git a/etc/guix-publish.service.in b/etc/guix-publish.service.in
index fc4e3c21f3..8aaf09e3cd 100644
--- a/etc/guix-publish.service.in
+++ b/etc/guix-publish.service.in
@@ -6,7 +6,7 @@
Description=Publish the GNU Guix store
[Service]
-ExecStart=@bindir@/guix publish --user=nobody --port=8181
+ExecStart=@localstatedir@/guix/profiles/per-user/root/guix-profile/bin/guix publish --user=nobody --port=8181
Environment=GUIX_LOCPATH=/root/.guix-profile/lib/locale
RemainAfterExit=yes
StandardOutput=syslog