summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-09 19:22:08 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-09 22:18:47 +0100
commitcd48eae560c76f93cec6cf3db7c8cd788b929a69 (patch)
tree8630465ef867f96bd3c30957a31d70254aa57d05 /configure.ac
parent6b6a0b143d487befb115bcbcb54de862c508f4f6 (diff)
downloadgnu-guix-cd48eae560c76f93cec6cf3db7c8cd788b929a69.tar
gnu-guix-cd48eae560c76f93cec6cf3db7c8cd788b929a69.tar.gz
build: Always check for gzip/bzip2/xz.
This allows (guix config) to contain valid values of %GZIP et al. even when configured with --disable-daemon. * config-daemon.ac: Move 'AC_PATH_PROG' invocations for gzip & co. to... * configure.ac: ... here.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 00e7c7b4bc..19efd08e64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,14 @@ GUIX_CHECK_LIBC_MOUNT
AM_CONDITIONAL([BUILD_SYSCALLS_MODULE],
[test "x$guix_cv_libc_has_mount" = "xyes"])
+dnl Decompressors, for use by the substituter and other modules.
+AC_PATH_PROG([GZIP], [gzip])
+AC_PATH_PROG([BZIP2], [bzip2])
+AC_PATH_PROG([XZ], [xz])
+AC_SUBST([GZIP])
+AC_SUBST([BZIP2])
+AC_SUBST([XZ])
+
AC_ARG_WITH([nix-prefix],
[AS_HELP_STRING([--with-nix-prefix=DIR],
[search for Nix in DIR (for testing purposes and '--disable-daemon' builds)])],