summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-08-27 15:38:59 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-02 16:43:10 +0200
commitfe634eaf93ba40862acdf62d7f197c6f19f0651c (patch)
tree1d0286c3c1610c328a2eb7b235744981ad9ec560 /build-aux
parent02fa1d251c9caeba39c7593e0b8ab52b60735b17 (diff)
downloadgnu-guix-fe634eaf93ba40862acdf62d7f197c6f19f0651c.tar
gnu-guix-fe634eaf93ba40862acdf62d7f197c6f19f0651c.tar.gz
Add (guix describe) and use it to initialize '%package-search-path'.
* guix/describe.scm: New file. * Makefile.am (MODULES): Add it. * gnu/packages.scm (%default-package-module-path): New variable. (%package-module-path): Honor 'package-path-entries'. * build-aux/update-NEWS.scm (main): Use %DEFAULT-PACKAGE-MODULE-PATH instead of (last (%package-module-path)).
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/update-NEWS.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/build-aux/update-NEWS.scm b/build-aux/update-NEWS.scm
index 2e8f68c9a8..a9dffef1d2 100644
--- a/build-aux/update-NEWS.scm
+++ b/build-aux/update-NEWS.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -128,11 +128,10 @@ paragraph."
(define (main . args)
(match args
((news-file data-directory)
- ;; Don't browse things listed in the user's $GUIX_PACKAGE_PATH. Here we
- ;; assume that the last item in (%package-module-path) is the distro
- ;; directory.
+ ;; Don't browse things listed in the user's $GUIX_PACKAGE_PATH and
+ ;; in external channels.
(parameterize ((%package-module-path
- (list (last (%package-module-path)))))
+ %default-package-module-path))
(define (package-file version)
(string-append data-directory "/packages-"
version ".txt"))