summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-01 01:46:15 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-01 01:46:15 +0100
commit0afdc48532ea7d8eea32b3e3b78ba3832e7f18b2 (patch)
tree666db7447c4b7e96c16241b6c6647bbac72290d0 /Makefile.am
parente3d741065e29b6f0d050592da853b641205c21bc (diff)
downloadgnu-guix-0afdc48532ea7d8eea32b3e3b78ba3832e7f18b2.tar
gnu-guix-0afdc48532ea7d8eea32b3e3b78ba3832e7f18b2.tar.gz
Add a preliminary `guix-package' command-line tool.
* guix-package.in, tests/guix-package.sh: New files. * configure.ac: Output `guix-package'. * Makefile.am (TESTS): Add `tests/guix-package.sh'. (bin_SCRIPTS): Add `guix-package'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d3a3dbf69a..8a564624b9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,8 @@
bin_SCRIPTS = \
guix-build \
- guix-download
+ guix-download \
+ guix-package
MODULES = \
guix/utils.scm \
@@ -120,7 +121,8 @@ TESTS = \
tests/build-utils.scm \
tests/packages.scm \
tests/union.scm \
- tests/guix-build.sh
+ tests/guix-build.sh \
+ tests/guix-package.sh
TEST_EXTENSIONS = .scm .sh