summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-04 22:31:48 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-14 11:16:58 +0200
commitc5a2e1ffcb029f50c4c18352cf378b61c41c625e (patch)
treed0b509f57430e6ffa40233fe8cd87d6bbd5b0a3c /Makefile.am
parent6892f0a247a06ac12c8c462692f8b3f93e872911 (diff)
downloadgnu-guix-c5a2e1ffcb029f50c4c18352cf378b61c41c625e.tar
gnu-guix-c5a2e1ffcb029f50c4c18352cf378b61c41c625e.tar.gz
build: Require Guile-SQLite3.
The next commits make (sqlite3) an indirect dependency of (gnu build install), which is itself used by (guix scripts system), hence this new requirement. * configure.ac: Error out when $guix_cv_have_recent_guile_sqlite3 is false. Remove HAVE_GUILE_SQLITE3 Automake conditional. * Makefile.am (MODULES, SCM_TESTS): Remove HAVE_GUILE_SQLITE3 conditions. * doc/guix.texi (Requirements): Add Guile-SQLite3. * README: Ditto. * gnu/packages/package-management.scm (guix)[propagated-inputs]: Add GUILE-SQLITE3. [arguments]: In 'wrap-program' phase, take guile-sqlite3 into account.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 3 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 0267e8fe50..f4cdba94a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -262,11 +262,7 @@ STORE_MODULES = \
guix/store/database.scm \
guix/store/deduplication.scm
-if HAVE_GUILE_SQLITE3
MODULES += $(STORE_MODULES)
-else
-MODULES_NOT_COMPILED += $(STORE_MODULES)
-endif !HAVE_GUILE_SQLITE3
# Internal modules with test suite support.
dist_noinst_DATA = guix/tests.scm guix/tests/http.scm
@@ -379,7 +375,9 @@ SCM_TESTS = \
tests/scripts-build.scm \
tests/containers.scm \
tests/pack.scm \
- tests/import-utils.scm
+ tests/import-utils.scm \
+ tests/store-database.scm \
+ tests/store-deduplication.scm
if HAVE_GUILE_JSON
@@ -391,14 +389,6 @@ SCM_TESTS += \
endif
-if HAVE_GUILE_SQLITE3
-
-SCM_TESTS += \
- tests/store-database.scm \
- tests/store-deduplication.scm
-
-endif
-
SH_TESTS = \
tests/guix-build.sh \
tests/guix-download.sh \